Some OneNote content created between May 14th, and May 18th, 2021, is not accessible

Incident
August 03, 8:30pm ADT

Some OneNote content created between May 14th, and May 18th, 2021, is not accessible

Status: Closed
Start: July 12, 6:39pm ADT
End: August 03, 8:30pm ADT
Duration: 22 days 1 hour 50 minutes
Affected Components:
Update

July 12, 6:39pm ADT

July 12, 6:39pm ADT

Title: Some OneNote content created between May 14th, and May 18th, 2021, is not accessible
User Impact: Users may notice that some OneNote edits created between May 14th, 2021, and May 18th, 2021, are unavailable.
More Info: While restoration of the impacted content progresses, users may notice an additional section added to their notebooks with the date in the following format (YY-MM-DD, e.g. 21-05-18(1)) that represents a snapshot of content from May 18th, 2021, prior to it becoming unavailable.
Current status: We’ve discovered an issue in which some of your users may notice that OneNote content that was edited by a user between May 14th, and May 18th, 2021, is unavailable. We’re currently working to restore access to the impacted OneNote content, and we’ll provide a timeline for restoration as soon as it becomes available.
Scope of impact: Your organization is affected by this event.
Start time: Friday, May 14th, 2021, at 12:00 AM UTC.
Root cause: A code issue caused OneNote content between May 14th, and May 18th, 2021, to not be saved properly. We’ve mitigated the issue going forward and included additional validations to prevent future occurrences of this issue.
Next update by: Friday, June 16, 2021, at 11:30 PM UTC

Update

July 16, 7:57pm ADT

July 16, 7:57pm ADT

More Info: While restoration of the impacted content progresses, users may notice an additional section added to their notebooks with the date in the following format (YY-MM-DD, e.g. 21-05-18(1)) that represents a snapshot of content from May 18th, 2021, prior to it becoming unavailable.
Current status: We're continuing to restore access to the impacted OneNote content. We expect this process to take an extended period to ensure access is properly restored.
Scope of impact: Your organization is affected by this event.
Start time: Friday, May 14th, 2021, at 12:00 AM UTC.
Root cause: A code issue caused OneNote content between May 14th, and May 18th, 2021, to not be saved properly. We’ve mitigated the issue going forward and included additional validations to prevent future occurrences of this issue.
Next update by: Tuesday, July 20, 2021, at 11:30 PM UTC

Update

July 20, 8:16pm ADT

July 20, 8:16pm ADT

More Info: While restoration of the impacted content progresses, users may notice an additional section added to their notebooks with the date in the following format (YY-MM-DD, e.g. 21-05-18(1)) that represents a snapshot of content from May 18th, 2021, prior to it becoming unavailable.
Current status: Our restoration efforts are progressing as expected. We continue to expect this work to take an extended period of time. At this point in the incident, we expect at least 95 percent of all users to be mitigated.
Scope of impact: Your organization is affected by this event.
Start time: Friday, May 14th, 2021, at 12:00 AM UTC.
Root cause: A code issue caused OneNote content between May 14th, and May 18th, 2021, to not be saved properly. We’ve mitigated the issue going forward and included additional validations to prevent future occurrences of this issue.
Next update by: Friday, July 23, 2021, at 11:30 PM UTC

Update

July 23, 8:12pm ADT

July 23, 8:12pm ADT

More Info: While restoration of the impacted content progresses, users may notice an additional section added to their notebooks with the date in the following format (YY-MM-DD, e.g. 21-05-18(1)) that represents a snapshot of content from May 18th, 2021, prior to it becoming unavailable.
Current status: Our recovery efforts are ongoing and approximately 98 percent of all users are no longer impacted by this event. We'll continue to work on restoring the remaining two percent.
Scope of impact: Your organization is affected by this event.
Start time: Friday, May 14th, 2021, at 12:00 AM UTC.
Root cause: A code issue caused OneNote content between May 14th, and May 18th, 2021, to not be saved properly. We’ve mitigated the issue going forward and included additional validations to prevent future occurrences of this issue.
Next update by: Wednesday, July 28, 2021, at 11:30 PM UTC

Update

July 28, 7:44pm ADT

July 28, 7:44pm ADT

More Info: While restoration of the impacted content progresses, users may notice an additional section added to their notebooks with the date in the following format (YY-MM-DD, e.g. 21-05-18(1)) that represents a snapshot of content from May 18th, 2021, prior to it becoming unavailable.
For clarity, an additional section will be created with a date after the name of the restored section(s).
Current status: We've completed the large majority of our restoration efforts. We're working on the very limited number of users that may remain impacted by this incident. We'll provide a more detailed update by our next update.
Scope of impact: Your organization is affected by this event.
Start time: Friday, May 14th, 2021, at 12:00 AM UTC
Root cause: A code issue caused OneNote content between May 14th, and May 18th, 2021, to not be saved properly. We’ve mitigated the issue going forward and included additional validations to prevent future occurrences of this issue.
Next update by: Wednesday, August 4, 2021, at 11:30 PM UTC

Update

August 03, 7:59pm ADT

August 03, 7:59pm ADT

More Info: While restoration of the impacted content progresses, users may notice an additional section added to their notebooks with the date in the following format (YY-MM-DD, e.g. 21-05-18(1)) that represents a snapshot of content from May 18th, 2021, prior to it becoming unavailable.
For clarity, an additional section will be created with a date after the name of the restored section(s).
Current status: We've completed our restoration efforts and we're continuing to monitor the service and for any customer reports that the issue is persisting.
Scope of impact: Your organization is affected by this event.
Start time: Friday, May 14th, 2021, at 12:00 AM UTC
Root cause: A code issue caused OneNote content between May 14th, and May 18th, 2021, to not be saved properly. We’ve mitigated the issue going forward and included additional validations to prevent future occurrences of this issue.
Next update by: Monday, August 9, 2021, at 11:30 PM UTC

Resolved

August 03, 8:30pm ADT

August 03, 8:30pm ADT

Title: Some OneNote content created between May 14th, and May 18th, 2021, was not accessible
User Impact: Users may have noticed that some OneNote edits created between May 14th, 2021, and May 18th, 2021, were unavailable.
More Info: While restoration of the impacted content progressed, users may have noticed an additional section added to their notebooks with the date in the following format (YY-MM-DD, e.g. 21-05-18(1)) that represented a snapshot of content from May 18th, 2021, prior to it becoming unavailable.
For clarity, an additional section was created with a date after the name of the restored section(s).
Final status: We've received confirmation via internal monitoring and customer reports that our restoration efforts were successful.
Scope of impact: Your organization was affected by this event.
Start time: Friday, May 14th, 2021, at 12:00 AM UTC
Root cause: A code issue caused OneNote content between May 14th, and May 18th, 2021, to not be saved properly. We’ve mitigated the issue going forward and included additional validations to prevent future occurrences of this issue.
Next update by: Tuesday, August 3, 2021, at 11:30 PM UTC

Resolved

August 03, 8:30pm ADT

August 03, 8:30pm ADT

Resolved