Users’ labels and classifications for Microsoft Word, Excel and PowerPoint documents may not function

Incident
November 01, 3:46pm ADT

Users’ labels and classifications for Microsoft Word, Excel and PowerPoint documents may not function

Status: Closed
Start: November 01, 2:37pm ADT
End: November 01, 3:25pm ADT
Duration: 47 minutes
Affected Components:
Update

November 01, 2:37pm ADT

November 01, 2:37pm ADT

Title: Users’ labels and classifications for Microsoft Word, Excel and PowerPoint documents may not function
User Impact: Users’ labels and classifications for Microsoft Word, Excel and PowerPoint documents may not function.
More info: This problem may inhibit the creation of new labels and classifications. Existing labels and classifications may fail to apply.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Resolved

November 01, 3:25pm ADT

November 01, 3:25pm ADT

Title: Users’ labels and classifications for Microsoft Word, Excel and PowerPoint documents may not function
User Impact: Users’ labels and classifications for Microsoft Word, Excel and PowerPoint documents may not have worked as expected.
More info: This problem may have prevented sensitivity labels from being recommended or auto-applied. Existing labels and classifications may have failed to apply.
Final status: After monitoring service telemetry, we've confirmed that our traffic processing optimizations have resolved the issue. Labels and classifications now work as expected.
Scope of impact: Your organization was affected by this event, and any user creating or utilizing existing labels and classifications may have been impacted.
Start time: Monday, November 1, 2021, at 2:30 PM UTC
End time: Monday, November 1, 2021, at 6:25 PM UTC
Root cause: Infrastructure that facilitates label and classification functionality became unbalanced and began processing traffic inefficiently, leading to impact.
Next steps: - We’re reviewing performance and health levels for the portion of infrastructure that wasn’t processing traffic as efficiently as expected in addition to investigating potential automated request balancing actions to prevent similar label and classification problems in the future.
This is the final update for the event.

Resolved

November 01, 3:25pm ADT

November 01, 3:25pm ADT

Resolved

Update

November 01, 3:46pm ADT

November 01, 3:46pm ADT

More info: This problem may inhibit the creation of new labels and classifications. Existing labels and classifications may fail to apply.
Current status: We've identified that infrastructure that facilitates label and classification functionality became unbalanced and began processing traffic inefficiently. We’ve implemented traffic processing optimizations to balance service load and remediate impact. We're monitoring service side telemetry to ensure that the issue is resolved.
Scope of impact: Your organization is affected by this event, and any user creating or utilizing existing labels and classifications may be impacted.
Start time: Monday, November 1, 2021, at 2:30 PM UTC
Root cause: Infrastructure that facilitates label and classification functionality became unbalanced and began processing traffic inefficiently, leading to impact.
Next update by: Monday, November 1, 2021, at 8:00 PM UTC