Some users' Exchange Online outgoing messages are delayed or stuck in the Drafts or Sent Items folder after sending

Incident
December 14, 8:35pm AST

Some users' Exchange Online outgoing messages are delayed or stuck in the Drafts or Sent Items folder after sending

Status: Closed
Start: December 14, 5:15pm AST
End: December 14, 8:35pm AST
Duration: 3 hours 19 minutes
Affected Components:
Update

December 14, 5:15pm AST

December 14, 5:15pm AST

Title: Some users' Exchange Online outgoing messages are delayed or stuck in the Drafts folder after sending
User Impact: Users' Exchange Online outgoing messages are delayed or stuck in the Drafts folder after sending.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 60 minutes.

Update

December 14, 5:51pm AST

December 14, 5:51pm AST

More info: Email that is stuck in the Drafts folder as well as some messages showing in the Sent folder aren't received by the recipient.
Current status: We're reviewing examples of affected user mailboxes alongside the associated impacted messages to better understand why this problem is occurring.
Scope of impact: This issue could affect any user sending email through the Exchange Online service.
Next update by: Tuesday, December 14, 2021, at 11:00 PM UTC

Update

December 14, 7:06pm AST

December 14, 7:06pm AST

More info: Email that is stuck in the Drafts folder as well as some messages showing in the Sent folder aren't received by the recipient.
Current status: We've identified that a recent routing configuration change on a portion of infrastructure that facilitates message submission resulted in an abnormally large number of messages routing through the affected infrastructure and queueing for delivery We're correcting the routing configuration change problem to mitigate this issue. We expect that this will complete by our next update; however, additional time will be required for all queued messages to be processed.
Scope of impact: This issue affects some users sending email through Exchange Online that are served through the affected infrastructure.
Start time: Tuesday, December 14, 2021, at 5:30 PM UTC
Root cause: A recent routing configuration change on a portion of infrastructure that facilitates message submission resulted in an abnormally large number of messages routing through the affected infrastructure and queuing for delivery.
Next update by: Wednesday, December 15, 2021, at 2:00 AM UTC

Resolved

December 14, 8:35pm AST

December 14, 8:35pm AST

Title: Some users' Exchange Online outgoing messages are delayed or stuck in the Drafts or Sent Items folder after sending
User Impact: Users' Exchange Online outgoing messages are delayed or stuck in the Drafts or Sent Items folder after sending.
More info: Email that was stuck in the Drafts folder as well as some messages showing in the Sent folder were actually queued for delivery, but hadn't been sent.
Final status: We've completed the routing configuration change deployment resolving the underlying issue and confirmed with users that current messages and previously queued mail is being delivered as expected.
Scope of impact: This issue affected some users sending email through Exchange Online that were served through the affected infrastructure.
Start time: Tuesday, December 14, 2021, at 5:30 PM UTC
End time: Wednesday, December 15, 2021, at 12:35 AM UTC
Root cause: A recent routing configuration change on a portion of infrastructure that facilitates message submission resulted in an abnormally large number of messages routing through the affected infrastructure, resulting in mail queueing.
Next steps: - We're reviewing our routing configuration update procedures to better identify and prevent similar problems that could result in sub-optimal request routing that effects Exchange Online mailflow.
This is the final update for the event.

Resolved

December 14, 8:35pm AST

December 14, 8:35pm AST

Resolved