External users encounter errors which prevent access to SharePoint Online sites which were shared to them

Incident
April 22, 1:39am ADT

External users encounter errors which prevent access to SharePoint Online sites which were shared to them

Status: Closed
Start: April 21, 10:48pm ADT
End: April 22, 1:39am ADT
Duration: 2 hours 50 minutes
Affected Components:
Update

April 21, 10:48pm ADT

April 21, 10:48pm ADT

Title: External users who attempt to access a SharePoint Online site which was shared to them are experiencing errors
User Impact: External users who attempt to access a SharePoint Online site which was shared to them are experiencing errors.
More info: Impact is specific to newly invited external users. External users attempting to access a SharePoint Online site that is shared to them are seeing the following error: "Something went wrong We're sorry, but we couldn't accept the invitation for (insert user's email that is attempting to access) at this time. Please try again later, while we try to automatically fix this for you"
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.
Scope of impact: Any external user attempting to access shared SharePoint Online sites is affected.

Update

April 21, 11:04pm ADT

April 21, 11:04pm ADT

More info: Impact is specific to newly invited external users. External users attempting to access a SharePoint Online site that is shared to them are seeing the following error: "Something went wrong We're sorry, but we couldn't accept the invitation for (insert user's email that is attempting to access) at this time. Please try again later, while we try to automatically fix this for you"
Current status: We're investigating service side logs to understand where impact is occurring. In parallel, we're investigating if there have been any recent changes which are causing impact to our service.
Scope of impact: Any external user attempting to access shared SharePoint Online sites is affected.
Next update by: Friday, April 22, 2022, at 3:00 AM UTC

Update

April 21, 11:56pm ADT

April 21, 11:56pm ADT

More info: Impact is specific to newly invited external users. External users attempting to access a SharePoint Online site that is shared to them are seeing the following error: "Something went wrong We're sorry, but we couldn't accept the invitation for (insert user's email that is attempting to access) at this time. Please try again later, while we try to automatically fix this for you"
Current status: We've identified a potential cause in our service logs so we're attempting to reproduce this issue to better understand what sites are affected and how we can remediate impact.
Scope of impact: Any external user attempting to access shared SharePoint Online sites is affected.
Next update by: Friday, April 22, 2022, at 5:00 AM UTC

Resolved

April 22, 1:39am ADT

April 22, 1:39am ADT

Current status: We've discovered a recent change intended to improve customer experience has inadvertently caused impact to our service. We've stopped the offending code change, which we have confirmed internally, will remediate impact. We're reaching out to some affected tenants to confirm impact is remediated.
Scope of impact: Any external user attempting to access shared SharePoint Online sites is affected.
Start time: Tuesday, April 19, 2022, at 7:11 AM UTC
Root cause: A recent change intended to improve customer experience has inadvertently caused impact to our service.
Next update by: Friday, April 22, 2022, at 7:00 AM UTC

Resolved

April 22, 1:39am ADT

April 22, 1:39am ADT

Final status: We've determined that stopping the offending code change was successfully completed and have received confirmation from some impacted users that the service is restored.
Scope of impact: Any external user attempting to access shared SharePoint Online sites was affected.
Start time: Tuesday, April 19, 2022, at 7:11 AM UTC
End time: Friday, April 22, 2022, at 4:39 AM UTC
Root cause: A recent change intended to improve customer experience inadvertently caused impact to our service.
Next steps: - We're reviewing the offending code change in order to prevent this from occurring in the future.
This is the final update for the event.