External users may have been unable to access shared OneDrive for Business content

Incident
April 26, 11:36am ADT

External users may have been unable to access shared OneDrive for Business content

Status: Closed
Start: April 26, 9:42am ADT
End: April 26, 11:36am ADT
Duration: 1 hour 53 minutes
Affected Components:
Update

April 26, 9:42am ADT

April 26, 9:42am ADT

Title: External users are unable to access shared OneDrive for Business content
User Impact: External users are unable to access shared OneDrive for Business content.
Current status: We're analyzing service monitoring telemetry to determine the root cause and develop a mitigation plan.
Scope of impact: Impact is specific to External users who are served through the affected infrastructure.
Next update by: Tuesday, April 26, 2022, at 1:30 PM UTC

Update

April 26, 10:13am ADT

April 26, 10:13am ADT

Current status: We're continuing to analyze service monitoring telemetry, in addition to network trace logs to help us determine the next troubleshooting steps.
Scope of impact: Impact is specific to external users who are served through the affected infrastructure.
Next update by: Tuesday, April 26, 2022, at 3:30 PM UTC

Resolved

April 26, 11:36am ADT

April 26, 11:36am ADT

Final status: We've identified that a recent standard service update unexpectedly introduced a code regression which resulted in impact. We've reverted the change and confirmed by monitoring service telemetry that the impact has been remediated.
Scope of impact: Impact was specific to external users who were served through the affected infrastructure.
Start time: Friday, April 22, 2022, at 5:02 AM UTC
End time: Tuesday, April 26, 2022, at 2:36 PM UTC
Root cause: A recent standard service update unexpectedly introduced a code regression which may have prevented external users from accessing shared OneDrive for Business content.
Next steps: - We're reviewing our standard service update procedures to avoid similar impact in the future.
This is the final update for the event.