Users may see 'Access Denied' errors when using Graph APIs for SharePoint Online

Incident
May 18, 9:55am ADT

Users may see 'Access Denied' errors when using Graph APIs for SharePoint Online

Status: Closed
Start: May 17, 1:31am ADT
End: May 18, 9:55am ADT
Duration: 1 day 8 hours 23 minutes
Affected Components:
Update

May 17, 1:31am ADT

May 17, 1:31am ADT

Title: Users may see 'Access Denied' errors when using Graph APIs for SharePoint Online
User Impact: Users may see 'Access Denied' errors when using Graph APIs for SharePoint Online.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Update

May 17, 1:58am ADT

May 17, 1:58am ADT

Current status: We're analyzing system logs to help identify the source of the 'Access Denied' errors.
Scope of impact: Your organization is affected by this event, and the issue may impact any user utilizing Graph APIs for SharePoint Online.
Next update by: Tuesday, May 17, 2022, at 6:30 AM UTC

Update

May 17, 3:28am ADT

May 17, 3:28am ADT

Current status: We reviewed the logs and identified a potential authentication issue with the Graph APIs. We're continuing our analysis of the authentication requests to determine our next troubleshooting steps.
Scope of impact: Your organization is affected by this event, and the issue may impact any user utilizing Graph APIs for SharePoint Online.
Next update by: Tuesday, May 17, 2022, at 8:30 AM UTC

Update

May 17, 5:22am ADT

May 17, 5:22am ADT

Current status: We've identified that a specific feature, responsible for authenticating and authorizing user requests, is not performing as expected and causing some access Graph API access requests to fail. We're reviewing the affected feature to develop a remediation plan.
Scope of impact: Your organization is affected by this event, and the issue may impact any user utilizing Graph APIs for SharePoint Online.
Next update by: Tuesday, May 17, 2022, at 10:30 AM UTC

Update

May 17, 7:26am ADT

May 17, 7:26am ADT

Current status: We've identified that components of the authentication feature are unexpectedly not present in some users' environments thus resulting in the Graph API access requests to fail. We're redeploying the affected feature within impacted environments to remediate impact. In parallel, we're investigating recent feature changes to identity why the components are unexpectedly not present.
Scope of impact: Your organization is affected by this event, and any user utilizing Graph APIs for SharePoint Online may be impacted.
Next update by: Tuesday, May 17, 2022, at 5:00 PM UTC

Update

May 17, 12:40pm ADT

May 17, 12:40pm ADT

Current status: We've confirmed that a recent feature deployment misconfiguration has prevented components associated with the authentication feature from being available in a group of customer environments, which is producing 'Access Denied' errors when using Graph APIs for SharePoint Online. We've confirmed that our redeployment of the authentication feature to some impacted environments has resolved the impact. We're now redeploying the feature to all affected remaining environments, which is expected to remediate impact.
Scope of impact: This issue may potentially affect any of your users attempting to utilize Graph APIs for SharePoint Online.
Root cause: A recent feature deployment misconfiguration has prevented an authentication feature from being available in a group of customer environments, resulting in impact.
Next update by: Tuesday, May 17, 2022, at 9:30 PM UTC

Update

May 17, 6:11pm ADT

May 17, 6:11pm ADT

Current status: We've completed redeploying the feature to all affected remaining environments. While we've received confirmation from multiple affected users that the impact is now remediated, our review of telemetry revealed errors continuing to persist for some environments. We're implementing additional tooling to extract logging that will assist us in determining why these errors persist and formulate appropriate steps to remediate these remaining environments.
Scope of impact: This issue may potentially affect any user attempting to utilize Graph APIs for SharePoint Online.
Root cause: A recent feature deployment misconfiguration has prevented an authentication feature from being available in a group of customer environments, resulting in impact.
Next update by: Wednesday, May 18, 2022, at 2:30 AM UTC

Resolved

May 18, 9:55am ADT

May 18, 9:55am ADT

Please note that services have been restored. If you continue to experience issues, please contact the Service Desk.