Service Performance
Incident
May 18, 11:09am ADT
Service Performance
Status: Closed
Start:
May 18, 9:14am ADT
End:
May 18, 11:09am ADT
Duration: 1 hour 55 minutes
Affected Components:
Printing Services
Update
May 18, 9:14am ADT
May 18, 9:14am ADT
On-campus printing is currently experiencing degraded services. Technology Services is aware of the issue and consultants are investigating the cause.
Technology Services will continue to provide regular updates.
Resolved
May 18, 11:09am ADT
May 18, 11:09am ADT
Please note that services have been restored. If you continue to experience issues, please contact the Service Desk.
Copyright (C) 2021.