Users are intermittently unable to automatically sync their OneDrive for Business content to their local computer

Incident
May 20, 9:00am ADT

Users are intermittently unable to automatically sync their OneDrive for Business content to their local computer

Status: Closed
Start: May 17, 11:41am ADT
End: May 20, 9:00am ADT
Duration: 2 days 21 hours 18 minutes
Affected Components:
Update

May 17, 11:41am ADT

May 17, 11:41am ADT

Title: Some users are unable to automatically sync their OneDrive for Business content
User Impact: Users are unable to automatically sync their OneDrive for Business content.
Current status: We're reviewing service monitoring telemetry to determine the root cause of the issue, and formulate a plan for remediation.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are impacted.
Next update by: Tuesday, May 17, 2022, at 5:00 PM UTC

Update

May 17, 2:00pm ADT

May 17, 2:00pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: We're continuing to investigate the delays by reviewing service-side logs and telemetry to both identify the source of the problem and how to promptly remediate this issue.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Next update by: Tuesday, May 17, 2022, at 7:00 PM UTC

Update

May 17, 3:45pm ADT

May 17, 3:45pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: Our review of service telemetry and logging indicates that requests from the OneDrive for Business service to a downstream service which facilitates file sync in the cloud have spiked, resulting in a resource management component suppressing some requests and causing the impact. We're reviewing options to potentially raise the limit of accepted requests to help alleviate impact while, in parallel, we're investigating the source of requests spikes to address the root issue and fully remediate impact.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Next update by: Tuesday, May 17, 2022, at 10:00 PM UTC

Update

May 17, 5:40pm ADT

May 17, 5:40pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: We've increased the availability for OneDrive for Business traffic requests to the dependent sync service to help alleviate impact. We're restarting sync service infrastructure on which this change was made, and anticipate it may take up to ten hours for the restarts to complete. Users may begin to see relief in the next few hours. In parallel, we're continuing to review Fiddler trace and Unified Logging Service (ULS) logging to identify the source of increasing One Drive for Business request traffic and determine methods to fully remediate impact.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Next update by: Wednesday, May 18, 2022, at 12:00 AM UTC

Update

May 17, 7:36pm ADT

May 17, 7:36pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: Restarts have completed to around 40 percent of the sync service infrastructure where the OneDrive for Business traffic intake availability change was made. We're observing lowered failure rates on our telemetry indicating that the issue should be seen even less frequently by users. We're continuing to review the aforementioned logs and data to help us define a root cause and long-term fix to the impact.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Next update by: Wednesday, May 18, 2022, at 7:00 PM UTC

Update

May 18, 3:50pm ADT

May 18, 3:50pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: Our review of the ULS and network traces indicates that a recent feature update intended to improve sync responsiveness potentially contained an error which we believe to be causing an unexpected increase in requests, resulting in impact. We're working to rebalance these requests to more quickly remediate impact and are monitoring as the failure rate decreases while in parallel expanding our investigation to include the feature update to confirm this as the underlying cause.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Next update by: Wednesday, May 18, 2022, at 10:00 PM UTC

Update

May 18, 5:31pm ADT

May 18, 5:31pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: We're continuing to monitor the environments as the rebalancing actions progress and are seeing a corresponding reduction in failures while continuing our review of the feature update that is suspected to have caused impact.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Next update by: Thursday, May 19, 2022, at 1:00 AM UTC

Update

May 18, 5:32pm ADT

May 18, 5:32pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: We're continuing to monitor the environments as the rebalancing actions progress and are seeing a corresponding reduction in failures while continuing our review of the feature update that is suspected to have caused impact.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Next update by: Thursday, May 19, 2022, at 1:00 AM UTC

Update

May 18, 7:33pm ADT

May 18, 7:33pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: Our efforts to rebalance the sync service infrastructure are progressing as expected, and our telemetry indicates that failures are continuing to reduce as traffic normalizes. We're continuing a phased rebalancing to avoid overloading the affected infrastructure as the fix progresses. In parallel, we're continuing our review of the potentially affected feature update to more precisely identify the root cause of the increase in requests and formulate a long-term strategy for remediation.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Root cause: A recent feature update intended to improve sync responsiveness potentially contained an error which we believe to be causing an unexpected increase in requests, resulting in impact.
Next update by: Thursday, May 19, 2022, at 2:30 AM UTC

Update

May 18, 10:15pm ADT

May 18, 10:15pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: The first portion of our rebalancing effort is continuing as expected and should complete by our next update to further resolve or reduce the frequency of this issue for some users. The second rebalancing effort will begin on Thursday, May 19, 2022. We'll provide an estimated timeline for the remaining rebalancing process once available.
Scope of impact: Some users attempting to automatically sync their OneDrive for Business content are intermittently impacted.
Root cause: A recent feature update intended to improve sync responsiveness potentially contained an error which we believe to be causing an unexpected increase in requests, resulting in impact.
Next update by: Thursday, May 19, 2022, at 5:30 PM UTC

Update

May 19, 2:00pm ADT

May 19, 2:00pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: The first portion of our rebalancing effort completed and has reduced the frequency of this issue for some users. We're initiating the second phase of our rebalancing efforts that we expect will further improve performance. In parallel, we're looking into the recent feature update to identify the specific point of failure that has resulted in impact, allowing us to create a strategy to completely resolve the issue.
Scope of impact: Any user attempting to automatically sync their OneDrive for Business content could be intermittently impacted.
Root cause: A recent feature update intended to improve sync responsiveness potentially contained an error which we believe to be causing an unexpected increase in requests, resulting in impact.
Next update by: Thursday, May 19, 2022, at 9:00 PM UTC

Update

May 19, 4:53pm ADT

May 19, 4:53pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: We're continuing our efforts to rebalance sync traffic, which telemetry confirms has been successful in reducing the frequency of this issue. Additionally, we're developing optimizations that can be applied to the service which we expect to further mitigate the impact.
Scope of impact: Any user attempting to automatically sync their OneDrive for Business content could be intermittently impacted.
Start time: Monday, May 16, 2022, at 12:00 AM UTC
Preliminary root cause: A recent feature update intended to improve sync responsiveness resulted in an increased amount of requests being processed at a suboptimal rate, resulting in impact.
Next update by: Friday, May 20, 2022, at 12:00 AM UTC

Update

May 19, 7:51pm ADT

May 19, 7:51pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: We're finalizing a suite of optimizations to ensure that service performance during peak traffic periods in the primarily affected environment remains stable. We expect these changes to begin deployment within the next two hours. Furthermore, we've nearly completed work to rebalance sync traffic within the affected region and will actively monitor service health to identify any additional required changes.
Scope of impact: Any user attempting to automatically sync their OneDrive for Business content could be intermittently impacted.
Start time: Monday, May 16, 2022, at 12:00 AM UTC
Root cause: A recent feature update intended to improve sync responsiveness resulted in an increased amount of requests being processed at a suboptimal rate, resulting in impact.
Next update by: Friday, May 20, 2022, at 1:30 AM UTC

Update

May 19, 9:00pm ADT

May 19, 9:00pm ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: We’ve initiated deployment of our optimization changes and we expect to see incremental performance improvement over the next several hours. Concurrently, our work to rebalance sync traffic is underway within the affected region and we're closely monitoring the service to ensure the environment remains stable.
Scope of impact: Any user attempting to automatically sync their OneDrive for Business content could be intermittently impacted.
Start time: Monday, May 16, 2022, at 12:00 AM UTC
Preliminary root cause: A recent feature update intended to improve sync responsiveness resulted in an increased amount of requests being processed at a suboptimal rate, resulting in impact.
Next update by: Friday, May 20, 2022, at 6:30 AM UTC

Update

May 20, 2:56am ADT

May 20, 2:56am ADT

More info: While we're focused on remediation, users have reported that pausing and resuming the sync client can successfully force a sync.
Current status: Our optimization changes are continuing to be deployed. While we expect gradual performance improvement as a result, we've completed our work to rebalance sync traffic to maintain consistent service functionality. We'll closely monitor the service over the next several hours to identify any additional required changes.
Scope of impact: Any user attempting to automatically sync their OneDrive for Business content could be intermittently impacted.
Start time: Monday, May 16, 2022, at 12:00 AM UTC
Preliminary root cause: A recent feature update intended to improve sync responsiveness resulted in an increased amount of requests being processed at a suboptimal rate, resulting in impact.
Next update by: Friday, May 20, 2022, at 6:30 PM UTC

Resolved

May 20, 9:00am ADT

May 20, 9:00am ADT

Title: Users are intermittently unable to automatically sync their OneDrive for Business content to their local computer
User Impact: Users were intermittently unable to automatically sync their OneDrive for Business content to their local computer.
More info: While we were focused on remediation, users reported that pausing and resuming the sync client successfully forced a sync.
Final status: The optimization changes completed their deployment and through extended service monitoring, we've confirmed that the impact to users is now resolved and no additional actions are required.
Scope of impact: Any user attempting to automatically sync their OneDrive for Business content could have been intermittently impacted.
Start time: Monday, May 16, 2022, at 5:45 AM UTC
End time: Friday, May 20, 2022, at 12:00 PM UTC
Preliminary root cause: A recent feature update intended to improve sync responsiveness resulted in an increased amount of requests being processed at a suboptimal rate, resulting in impact.
Next steps: - We'll continue to monitor telemetry to ensure the service remains stable.
We'll publish a post-incident report within five business days.

Resolved

May 20, 9:00am ADT

May 20, 9:00am ADT

Resolved