Users may be unable to open or save Office 365 files in edit mode from SharePoint Online lists

Incident
August 12, 7:20am ADT

Users may be unable to open or save Office 365 files in edit mode from SharePoint Online lists

Status: Closed
Start: August 08, 5:23pm ADT
End: August 12, 7:20am ADT
Duration: 3 days 13 hours 56 minutes
Affected Components:
Update

August 08, 5:23pm ADT

August 08, 5:23pm ADT

Title: Users can't open recently created Excel files from within SharePoint Online lists
User Impact: Users are encountering an error when attempting to open Excel workbooks from SharePoint Online lists.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Update

August 08, 5:39pm ADT

August 08, 5:39pm ADT

More info: Affected users will see the following error:
"The workbook cannot be opened"
Current status: We're reviewing recent service updates which may be contributing to impact.
Scope of impact: Any user hosted on the affected infrastructure will be impacted.
Next update by: Monday, August 8, 2022, at 10:00 PM UTC

Update

August 08, 6:55pm ADT

August 08, 6:55pm ADT

More info: Affected users will see the following error:
"The workbook cannot be opened"
Current status: We've confirmed that a recent service update contains a code error within the previewing function which is causing an exception, resulting in impact. We're in the process of developing and validating a fix and expect to have a deployment timeline by the next scheduled update.
Scope of impact: Any user hosted on the affected infrastructure will be impacted.
Root cause: A recent service update contains a code error within the previewing function which is causing an exception, resulting in impact.
Next update by: Tuesday, August 9, 2022, at 6:30 AM UTC

Update

August 09, 2:30am ADT

August 09, 2:30am ADT

More info: Affected users will see the following error:
"The workbook cannot be opened"
Current status: The fix has been submitted and we anticipate that deployment of the fix will start within the next one to three days. We're monitoring its progress to ensure the fix gets deployed and saturates throughout the affected environment.
Scope of impact: Any user hosted on the affected infrastructure will be impacted.
Root cause: A recent service update contains a code error within the previewing function which is causing an exception, resulting in impact.
Next update by: Thursday, August 11, 2022, at 9:00 AM UTC

Update

August 09, 11:53am ADT

August 09, 11:53am ADT

More info: Users may encounter the error message "The workbook cannot be opened", when attempting to open Office 365 files from SharePoint Online lists, resulting in read-only view.
Current status: The previously submitted fix does not fully address the outlying issue. We're looking into Unified Logging Service (ULS) logs and recent changes, to form a remediation plan.
Scope of impact: Any user hosted on the affected infrastructure and attempting to open or save Office 365 files in edit mode from SharePoint Online lists may be impacted.
Root cause: A recent change contains a code error within the previewing function which is causing an exception, resulting in impact.
Next update by: Thursday, August 11, 2022, at 6:00 PM UTC

Update

August 09, 3:01pm ADT

August 09, 3:01pm ADT

More info: Users may encounter the error message "The workbook cannot be opened", when attempting to open Office 365 files from SharePoint Online lists, resulting in read-only view.
Current status: We suspect that a file locking issue may be causing this impact. We're reviewing an internal reproduction of the issue to deepen our understanding and formulate appropriate next steps.
Scope of impact: Any user hosted on the affected infrastructure and attempting to open or save Office 365 files in edit mode from SharePoint Online lists may be impacted.
Next update by: Tuesday, August 9, 2022, at 10:30 PM UTC

Update

August 09, 7:16pm ADT

August 09, 7:16pm ADT

More info: Users may encounter the error message "The workbook cannot be opened", when attempting to open Office 365 files from SharePoint Online lists, resulting in read-only view.
Current status: We've confirmed that a recent service update contained a code error that resulted in a file locking scenario within the file preview feature. The impact of this is preventing users from opening or saving Office 365 files in edit mode from SharePoint Online lists. We've developed and are in the process of validating a fix via our internal testing environment to confirm it effectively remediates this issue for newly created files. In parallel, we are in the process of determining if additional actions are required to fully resolve this issue.
Scope of impact: Any user hosted on the affected infrastructure and attempting to open or save Office 365 files in edit mode from SharePoint Online lists may be impacted.
Preliminary Root cause: A recent service update contained a code error that resulted in a file locking scenario within the previewing function, preventing users from opening or saving Office 365 files in edit mode from SharePoint Online lists.
Next update by: Wednesday, August 10, 2022, at 12:30 AM UTC

Update

August 09, 9:00pm ADT

August 09, 9:00pm ADT

More info: Users may encounter the error message "The workbook cannot be opened", when attempting to open Office 365 files from SharePoint Online lists, resulting in read-only view.
Current status: We've validated the fix for net new files via our internal testing environment and have completed targeted deployments to remediate impact. We've confirmed that additional actions are required to fully resolve this issue for previously impacted files, and we're in the process of developing a fix to repair the affected files. In parallel, we're reviewing our telemetry and signals to identify all files that were affected prior to completion of the aforementioned fix.
Scope of impact: Any user hosted on the affected infrastructure and attempting to open or save Office 365 files in edit mode from SharePoint Online lists may be impacted.
Start time: Wednesday, August 3, 2022, at 12:00 PM UTC
Preliminary Root cause: A recent service update contained a code error that resulted in a file locking scenario within the previewing function, preventing users from opening or saving Office 365 files in edit mode from SharePoint Online lists.
Next update by: Wednesday, August 10, 2022, at 7:30 PM UTC

Update

August 10, 3:02pm ADT

August 10, 3:02pm ADT

More info: Users may encounter the error message "The workbook cannot be opened", when attempting to open Office 365 files from SharePoint Online lists, resulting in read-only view.
Current status: Our efforts to deploy a fix to repair files affected prior to the previous mitigation activity are ongoing. We have since developed two fixes, one that will auto-mitigate this issue, and the other that will ensure we have resolved all impacted files. We're currently in the process of testing and validating these fixes in our pre-production environments, and once it has been confirmed they are successful, we will proceed with deploying them Worldwide.
Scope of impact: Any user hosted on the affected infrastructure and attempting to open or save Office 365 files in edit mode from SharePoint Online lists may be impacted.
Start time: Wednesday, August 3, 2022, at 12:00 PM UTC
Preliminary Root cause: A recent service update contained a code error that resulted in a file locking scenario within the previewing function, preventing users from opening or saving Office 365 files in edit mode from SharePoint Online lists.
Next update by: Thursday, August 11, 2022, at 7:30 PM UTC

Resolved

August 12, 7:20am ADT

August 12, 7:20am ADT

If you continue to experience issues, please contact the Service Desk.