Admins may be unable to perform migrations to Microsoft Teams channels via the SharePoint Migration Tool (SPMT)

Incident
October 28, 11:20pm ADT

Admins may be unable to perform migrations to Microsoft Teams channels via the SharePoint Migration Tool (SPMT)

Status: Closed
Start: October 26, 7:11pm ADT
End: October 28, 11:20pm ADT
Duration: 2 days 4 hours 8 minutes
Affected Components:
Update

October 26, 7:11pm ADT

October 26, 7:11pm ADT

Title: Admins may be unable to perform migrations to Microsoft Teams channels via the SharePoint Migration Tool (SPMT) User impact: Admins may be unable to perform migrations to Microsoft Teams channels via the SPMT.
More info: This issue also affects admins when performing migrations via the Migration Manager tool.
Admins may see this error when migrating content to Microsoft Teams channels: "Errors or timeout for Server Processing the file: Not all the items in the package have been migrated".
Current status: We're investigating system logs to isolate the origin of this issue.
Scope of impact: Any admin that's performing migrations to Microsoft Teams channels utilizing the SPMT or Migration Manager tool are impacted.
Next update: Wednesday, October 26, 2022, at 11:30 PM UTC

Update

October 26, 8:34pm ADT

October 26, 8:34pm ADT

More info: This issue also affects admins when performing migrations via the Migration Manager tool.
Admins may see this error when migrating content to Microsoft Teams channels: "Errors or timeout for Server Processing the file: Not all the items in the package have been migrated".
Current status: We're continuing our investigation of system logs that capture the impact to isolate the source of the errors and formulate a strategy for remediation.
Scope of impact: Any admin that's performing migrations to Microsoft Teams channels utilizing the SPMT or Migration Manager tool are impacted.
Next update by: Thursday, October 27, 2022, at 3:30 AM UTC

Update

October 26, 11:09pm ADT

October 26, 11:09pm ADT

More info: This issue also affects admins when performing migrations via the Migration Manager tool.
Admins may see this error when migrating content to Microsoft Teams channels: "Errors or timeout for Server Processing the file: Not all the items in the package have been migrated".
Current status: After further review, we identified that there are errors when using the SPMT for migrations to Microsoft Teams channels. We're reviewing system logs to identify what is triggering the migration failures, which will help us determine our next troubleshooting steps.
Scope of impact: Any admin that's performing migrations to Microsoft Teams channels utilizing the SPMT or Migration Manager tool are impacted.
Next update by: Friday, October 28, 2022, at 3:30 AM UTC

Update

October 27, 11:47pm ADT

October 27, 11:47pm ADT

More info: This issue also affects admins when performing migrations via the Migration Manager tool.
Admins may see this error when migrating content to Microsoft Teams channels: "Errors or timeout for Server Processing the file: Not all the items in the package have been migrated". Current status: We've determined that an update error is blocking SharePoint Online folder data from being updated in Microsoft Teams channels when admins attempt migrations via the SPMT. We're developing a code change to fix the error and allow migration jobs to update folder data in channels. Scope of impact: Any admin that's performing migrations to Microsoft Teams channels utilizing the SPMT or Migration Manager tool are impacted. Start time: Wednesday, October 19, 2022, at 12:00 AM UTC Root cause: An update error is blocking SharePoint Online folder data from being updated in Microsoft Teams channels when admins attempt migrations via the SPMT. Next update by: Friday, October 28, 2022, at 11:00 PM UTC

Update

October 28, 7:10pm ADT

October 28, 7:10pm ADT

More info: This issue also affects admins when performing migrations via the Migration Manager tool.
Admins may see this error when migrating content to Microsoft Teams channels: "Errors or timeout for Server Processing the file: Not all the items in the package have been migrated". Current status: We're continuing to develop a fix for this issue, which we expect will take some time to complete testing and validation. Once complete, we'll prepare the fix for deployment and evaluate possible expeditions to the fix to ensure impact is remediated as soon as possible. Scope of impact: Any admin that's performing migrations to Microsoft Teams channels utilizing the SPMT or Migration Manager tool are impacted. Start time: Wednesday, October 19, 2022, at 12:00 AM UTC Root cause: An update error is blocking SharePoint Online folder data from being updated in Microsoft Teams channels when admins attempt migrations via the SPMT. Next update by: Monday, October 31, 2022, at 9:00 PM UTC

Resolved

October 28, 11:20pm ADT

October 28, 11:20pm ADT

Title: Admins can't perform migrations to Microsoft Teams channels via SharePoint Migration Tool (SPMT) and Migration Manager
User Impact: Admins were unable to perform migrations to Microsoft Teams channels via the SPMT and the Migration Manager tool.
More info: Admins may have seen the following error when migrating content to Microsoft Teams channels: "Errors or timeout for Server Processing the file: Not all the items in the package have been migrated".
Final status: While working to prepare a code fix, we determined that disabling the offending code portion would be a more efficient and expeditious means of remediating impact. The code portion was successfully disabled, and we've confirmed with previously affected users that the issue is now resolved. Scope of impact: Any admin performing SharePoint Online content migrations to Microsoft Teams channels utilizing the SPMT or Migration Manager tool was impacted. Start time: Wednesday, October 19, 2022, at 12:00 AM UTC End time: Saturday, October 29, 2022, at 2:20 AM UTC Preliminary root cause: An error was blocking SharePoint Online folder data from being updated in Microsoft Teams channels when admins attempted content migrations. Next steps: - We're continuing to investigate how the error which blocked the migrations was introduced to prevent similar issues from happening in the future. We’ll publish a post-incident report within five business days.

Resolved

October 28, 11:20pm ADT

October 28, 11:20pm ADT

Resolved