Some users may be unable to render apps or web parts leveraging the SharePoint Framework (SPFx) in SharePoint Online

Incident
November 24, 1:02pm AST

Some users may be unable to render apps or web parts leveraging the SharePoint Framework (SPFx) in SharePoint Online

Status: Closed
Start: November 01, 3:08pm ADT
End: November 24, 1:02pm AST
Duration: 22 days 22 hours 53 minutes
Affected Components:
Update

November 01, 3:08pm ADT

November 01, 3:08pm ADT

Title: Some users may be unable to render apps or web parts leveraging the SharePoint Framework (SPFx) in SharePoint Online
User Impact: Users may be unable to render apps or web parts leveraging the SPFx in SharePoint Online.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Update

November 01, 3:41pm ADT

November 01, 3:41pm ADT

Current status: Our investigation has determined that a recent configuration change in the SharePoint Online infrastructure responsible for fulfilling web part content requests contained a conflict that prevented some requests from reaching the appropriate database, resulting in impact. We've reverted the configuration to its most recent healthy state to repair this issue, and we're testing to confirm that the affected web parts have been restored and impact is remediated.
Scope of impact: Some users accessing a SharePoint Online site containing apps or web parts may be affected.
Start time: Monday, October 31, 2022, at 12:30 PM UTC
Root cause: A recent configuration change in the SharePoint Online infrastructure responsible for fulfilling web part content requests contained a conflict that prevented some requests from reaching the appropriate database, resulting in impact.
Next update by: Tuesday, November 1, 2022, at 8:00 PM UTC

Update

November 01, 5:18pm ADT

November 01, 5:18pm ADT

Current status: We're awaiting word from affected customers to confirm that the affected web parts have been restored and impact is remediated.
Scope of impact: Some users accessing a SharePoint Online site containing apps or web parts may be affected.
Start time: Monday, October 31, 2022, at 12:30 PM UTC
Root cause: A recent configuration change in the SharePoint Online infrastructure responsible for fulfilling web part content requests contained a conflict that prevented some requests from reaching the appropriate database, resulting in impact.
Next update by: Tuesday, November 1, 2022, at 10:30 PM UTC

Update

November 01, 6:26pm ADT

November 01, 6:26pm ADT

Current status: While our telemetry suggests that the majority of impact has been resolved, we see some errors occurring that could be due to apps and web parts accessing cached data storage, which should automatically refresh after a 24-hour period. We're initiating an extended monitoring period to ensure that the affected web parts have been restored and impact is remediated.
Scope of impact: Some users accessing a SharePoint Online site containing apps or web parts may be affected.
Start time: Monday, October 31, 2022, at 12:30 PM UTC
Root cause: A recent configuration change in the SharePoint Online infrastructure responsible for fulfilling web part content requests contained a conflict that prevented some requests from reaching the appropriate database, resulting in impact.
Next update by: Wednesday, November 2, 2022, at 9:00 PM UTC

Resolved

November 24, 1:02pm AST

November 24, 1:02pm AST

Please note that services have been restored. If you continue to experience issues, please contact the Service Desk.