Users' Public Switched Telephone Network (PSTN) calls may unexpectedly drop in Microsoft Teams when transferred

Incident
February 16, 11:38am AST

Users' Public Switched Telephone Network (PSTN) calls may unexpectedly drop in Microsoft Teams when transferred

Status: Closed
Start: February 16, 5:31am AST
End: February 16, 11:38am AST
Duration: 6 hours 6 minutes
Affected Components:
Update

February 16, 5:31am AST

February 16, 5:31am AST

Title: Users' Public Switched Telephone Network (PSTN) calls may be unexpectedly disconnected in Microsoft Teams
User impact: Users' PSTN calls may be unexpectedly disconnected in Microsoft Teams.
More info: This is affecting PSTN calls within voice applications.
Current status: We're reviewing service monitoring determine the root cause of impact and our next steps towards remediation.
Scope of impact: Your organization is affected by this event, and any user making PSTN calls in calling applications may be impacted.
Next update: Thursday, February 16, 2023 at 11:30 AM UTC

Update

February 16, 7:22am AST

February 16, 7:22am AST

User impact: Users' PSTN calls may be unexpectedly disconnected in Microsoft Teams.
More info: This is affecting PSTN calls within voice applications.
Current status: We're analyzing a sample of failed calls to locate the cause of impact and identify a mitigation plan.
Scope of impact: Your organization is affected by this event, and any user making PSTN calls in calling applications may be impacted.
Next update: Thursday, February 16, 2023 at 1:30 PM UTC

Update

February 16, 8:25am AST

February 16, 8:25am AST

User impact: Users' PSTN calls may be unexpectedly disconnected in Microsoft Teams when transferred.
More info: Only transferred call queue and auto attendant PSTN calls are affected.
Current status: We're continuing to review failed call samples to aid our investigation into the root cause.
Scope of impact: Our telemetry indicates that approximately 9% of PSTN call transfers to call queues or auto attendants are affected.
Next update by: Thursday, February 16, 2023, at 2:30 PM UTC

Update

February 16, 10:28am AST

February 16, 10:28am AST

User impact: Users' PSTN calls may be unexpectedly disconnected in Microsoft Teams when transferred.
More info: Only transferred call queue and auto attendant PSTN calls are affected.
Current status: Our investigation thus far into failed call samples has been inconclusive. We're reviewing any ongoing and recent deployments that may be contributing to impact.
Scope of impact: Our telemetry indicates that approximately 9% of PSTN call transfers to call queues or auto attendants are affected.
Next update by: Thursday, February 16, 2023, at 4:30 PM UTC

Resolved

February 16, 11:38am AST

February 16, 11:38am AST

Title: Some users' calls may unexpectedly disconnect in Microsoft Teams when made or transferred to the call queue
User impact: Users' calls may have been unexpectedly disconnected in Microsoft Teams when made or transferred to the call queue.
More info: Only transferred call queue and auto attendant calls were affected.
Final status: We identified that a configuration set in a recent service update disrupted a network routing component, resulting in impact when calls were made to Microsoft Teams call queues. We corrected this configuration and used internal monitoring telemetry to confirm that impact is remediated.
Scope of impact: Approximately nine percent of call transfers to call queues or auto attendants were affected.
Start time: Monday, February 13, 2023, at 10:16 PM UTC
End time: Thursday, February 16, 2023, at 3:38 PM UTC
Root cause: A configuration set in a recent service update disrupted a network routing component, resulting in impact when calls were made to Microsoft Teams call queues.
Next steps: - We're reviewing the service update validation process to improve the detection of similar issues in the future.
This is the final update for the event.

Resolved

February 16, 11:38am AST

February 16, 11:38am AST

Resolved