Teams users with Human Interface Devices (HID) may experience persisting dial tones or other degraded functionality

Incident
February 21, 4:19pm AST

Teams users with Human Interface Devices (HID) may experience persisting dial tones or other degraded functionality

Status: In Progress
Start: February 17, 8:40am AST
Affected Components:
Update

February 17, 12:56pm AST

February 17, 12:56pm AST

More info: This issue only affects the Teams desktop client and Windows Microsoft Teams Room (MTR) devices, and only when those devices had an HID connected during a recently terminated meeting. Users may experience the following impact scenarios: - Device peripheral call indicators, such as an LED display, may not turn off as expected when a Teams meeting ends. - For users utilizing on-premises Skype for Business with Microsoft Teams in coexistence mode, a persistent dial-tone during Microsoft Teams calls may be experienced. - If users were muted during a meeting, users may experience being unable to unmute during subsequent meetings. Users may restart their Microsoft Teams client to mitigate this impact.
This commonly affects users with a HID such as an audio headset. More information regarding HIDs can be found here: https://learn.microsoft.com/en-us/windows-hardware/drivers/hid/
While the fix is being deployed, we can disable the HID feature for your organization to temporarily mitigate this issue if requested. However, users won't be able to use Mute/Unmute or Hook/OffHook controls from their headset devices until the full fix is available.
Current status: We've completed development of the updated fix and are monitoring as it progresses through our validation procedures. We expect to have an updated deployment timeline by the next scheduled update.
Scope of impact: This issue specifically affected Microsoft Teams users with a HID connected, and only impacted the Microsoft Teams desktop client and Windows MTR devices.
Start time: Wednesday, December 7, 2022, at 1:34 AM UTC
Root cause: Changes to improve the HID feature for Microsoft Teams users introduced a code issue, causing degraded functionality to some users with these device types attached to their Teams client.
Next update by: Saturday, February 18, 2023, at 12:00 AM UTC

Update

February 17, 6:51pm AST

February 17, 6:51pm AST

More info: This issue only affects the Teams desktop client and Windows Microsoft Teams Room (MTR) devices, and only when those devices had an HID connected during a recently terminated meeting. Users may experience the following impact scenarios: - Device peripheral call indicators, such as an LED display, may not turn off as expected when a Teams meeting ends. - For users utilizing on-premises Skype for Business with Microsoft Teams in coexistence mode, a persistent dial-tone during Microsoft Teams calls may be experienced. - If users were muted during a meeting, users may experience being unable to unmute during subsequent meetings. Users may restart their Microsoft Teams client to mitigate this impact.
This commonly affects users with a HID such as an audio headset. More information regarding HIDs can be found here: https://learn.microsoft.com/en-us/windows-hardware/drivers/hid/
While the fix is being deployed, we can disable the HID feature for your organization to temporarily mitigate this issue if requested. However, users won't be able to use Mute/Unmute or Hook/OffHook controls from their headset devices until the full fix is available.
Current status: We're continuing our validation of the updated fix and expect deployment to start by the next scheduled update.
Scope of impact: This issue specifically affected Microsoft Teams users with a HID connected, and only impacted the Microsoft Teams desktop client and Windows MTR devices.
Start time: Wednesday, December 7, 2022, at 1:34 AM UTC
Root cause: Changes to improve the HID feature for Microsoft Teams users introduced a code issue, causing degraded functionality to some users with these device types attached to their Teams client.
Next update by: Tuesday, February 21, 2023, at 10:00 PM UTC

Update

February 21, 4:19pm AST

February 21, 4:19pm AST

User impact: Users with HIDs attached when disconnecting from a Teams meeting may subsequently experience degraded functionality.
More info: This issue only affects the Teams desktop client and Windows Microsoft Teams Room (MTR) devices, and only when those devices had an HID connected during a recently terminated meeting. Users may experience the following impact scenarios: - Device peripheral call indicators, such as an LED display, may not turn off as expected when a Teams meeting ends. - For users utilizing on-premises Skype for Business with Microsoft Teams in coexistence mode, a persistent dial-tone during Microsoft Teams calls may be experienced. - If users were muted during a meeting, users may experience being unable to unmute during subsequent meetings. Users may restart their Microsoft Teams client to mitigate this impact.
This commonly affects users with a HID such as an audio headset. More information regarding HIDs can be found here: https://learn.microsoft.com/en-us/windows-hardware/drivers/hid/
While the fix is being deployed, we can disable the HID feature for your organization to temporarily mitigate this issue if requested. However, users won't be able to use Mute/Unmute or Hook/OffHook controls from their headset devices until the full fix is available.
Current status: We've initiated the deployment of our updated fix and we're monitoring as it progresses, with current observations indicating that it's 40 percent complete. We expect that it will finish and remediate impact on Wednesday, February 22, 2023.
Scope of impact: This issue specifically affects Microsoft Teams users with a HID connected, and only impacts the Microsoft Teams desktop client and Windows MTR devices.
Start time: Wednesday, December 7, 2022, at 1:34 AM UTC
Root cause: Changes to improve the HID feature for Microsoft Teams users introduced a code issue, causing degraded functionality to some users with these device types attached to their Teams client.
Next update by: Wednesday, February 22, 2023, at 10:00 PM UTC