Some users may be unable to update their presence within Microsoft Teams

Incident
March 16, 9:46am ADT

Some users may be unable to update their presence within Microsoft Teams

Status: Closed
Start: March 16, 8:19am ADT
End: March 16, 9:30am ADT
Duration: 1 hour 10 minutes
Affected Components:
Update

March 16, 8:19am ADT

March 16, 8:19am ADT

Title: Some users may be unable to update their presence within Microsoft Teams
User impact: Users may be unable to update their presence within Microsoft Teams.
Current status: We're reviewing service monitoring telemetry to isolate the source of the issue and establish a fix.
Scope of impact: Impact is specific to some users who are served through the affected infrastructure.
Next update by: Thursday, March 16, 2023, at 1:30 PM UTC

Resolved

March 16, 9:30am ADT

March 16, 9:30am ADT

Title: Some users may be unable to update their presence within Microsoft Teams
User impact: Users may have been unable to update their presence within Microsoft Teams.
Final status: Additional analysis into the offending service change, we've determined that the deployment process itself was causing the impact. Due to this, the planned revert and fix weren't necessary. After halting the change, our internal validation confirmed that impact had been remediated.  Scope of impact: Impact was specific to some users who were served through the affected infrastructure. Start time: Thursday, March 16, 2023, at 4:10 AM UTC End time: Thursday, March 16, 2023, at 12:30 PM UTC Root cause: A deployment process problem for a recent service update caused an error causing unexpected failures when updating presence within Microsoft Teams. Next steps: - We're further analyzing our service update and change deployment processes to better understand why it caused the failures in updating presence to avoid similar problems in the future.
This is the final update for this event.

Resolved

March 16, 9:30am ADT

March 16, 9:30am ADT

Resolved

Update

March 16, 9:46am ADT

March 16, 9:46am ADT

User impact: Users may be unable to update their presence within Microsoft Teams.
Current status: We've identified that a recent update intended to enhance service functionality has inadvertently introduced an error causing unexpected failures in updating presence within Microsoft Teams. We're currently in the process of developing the fix to revert the offending update and expect to have a remediation timeline by our next scheduled update.
Scope of impact: Impact is specific to some users who are served through the affected infrastructure.
Start time: Wednesday, March 15, 2023, at 9:13 AM UTC
Root cause: A recent update intended to enhance service functionality has inadvertently introduced an error causing unexpected failures in updating presence within Microsoft Teams.
Next update by: Thursday, March 16, 2023, at 10:00 PM UTC