Admins may be unable to manage users in the Microsoft Teams Admin center

Incident
March 17, 7:27am ADT

Admins may be unable to manage users in the Microsoft Teams Admin center

Status: Closed
Start: March 17, 6:15am ADT
End: March 17, 7:19am ADT
Duration: 1 hour 3 minutes
Affected Components:
Update

March 17, 6:15am ADT

March 17, 6:15am ADT

Title: Possible delays or problems when accessing Microsoft Teams
User impact: Some customers have reported issues with accessing the service, or using features in Microsoft Teams.
Current status: We’re looking into your reported issue and checking for impact to your organization. We'll provide an update within one hour.

Update

March 17, 6:46am ADT

March 17, 6:46am ADT

User impact: Admins may be unable to manage users in the Microsoft Teams Admin center.
Current status: We’re reviewing diagnostic data to determine the root cause of impact.
Scope of impact: Impact is specific to admins affected through the affected infrastructure and may impact any admin attempting to manage users in the Microsoft Teams Admin center.
Next update time: Friday, March 17, 2023 at 11:00 AM UTC

Resolved

March 17, 7:19am ADT

March 17, 7:19am ADT

Title: Admins may have been unable to manage users in the Microsoft Teams Admin center
User impact: Admins may have been unable to manage users in the Microsoft Teams Admin center.
Final status: We've determined that a recent configuration change, designed to improve backend service operations, caused an issue where invalid data was being forwarded to internal services, which resulted in requests failing, causing impact. We've reverted the change to mitigate impact.   Scope of impact: This issue may have impacted any admin attempting to manage users in the Microsoft Teams Admin center.
Start time: Friday, March 17, 2023, at 5:02 AM UTC
End time: Friday, March 17, 2023, at 10:19 AM UTC
Preliminary root cause: A recent configuration change, designed to improve backend service operations, caused an issue where invalid data was being forwarded to internal services, which resulted in requests failing, causing impact.
Next steps: - We're reviewing our standard service update procedures to avoid similar impact in the future.
We’ll publish a post-incident report within five business days.

Resolved

March 17, 7:19am ADT

March 17, 7:19am ADT

Resolved

Update

March 17, 7:27am ADT

March 17, 7:27am ADT

User impact: Admins may be unable to manage users in the Microsoft Teams Admin center.
User impact: Admins may be unable to manage users in the Microsoft Teams Admin center.
Current status: We've identified a recent configuration change that may be contributing to impact, whilst we work to isolate the root cause we're reverting the change to mitigate impact.   Scope of impact: This issue may impact any admin attempting to manage users in the Microsoft Teams Admin center.
Start time: Friday, March 17, 2023, at 5:02 AM UTC
Next update time: Friday, March 17, 2023 at 11:30 AM UTC