Anonymous users may be unable to join Microsoft Teams meetings through the Safari browser

Incident
March 24, 2:40pm ADT

Anonymous users may be unable to join Microsoft Teams meetings through the Safari browser

Status: Closed
Start: March 24, 1:00pm ADT
End: March 24, 2:40pm ADT
Duration: 1 hour 39 minutes
Affected Components:
Update

March 24, 1:00pm ADT

March 24, 1:00pm ADT

Title: Anonymous users may be unable to join Microsoft Teams meetings through the Safari browser
User impact: Anonymous users may be unable to join Microsoft Teams meetings through the Safari browser.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Update

March 24, 1:23pm ADT

March 24, 1:23pm ADT

User impact: Anonymous users may be unable to join Microsoft Teams meetings through the Safari browser.
Current status: Our investigation determined that a recent update to service components facilitating authentication and meeting joining for anonymous users contains a code conflict that's causing impact. We're determining how best to remediate this issue. Scope of impact: This issue may affect any anonymous user attempting to join Microsoft Teams meetings through the Safari browser. Start time: Thursday, March 23, 2023, at 11:00 AM UTC Root cause: A recent update to service components facilitating authentication and meeting joining for anonymous users contains a code conflict that's causing impact. Next update by: Friday, March 24, 2023, at 5:30 PM UTC

Update

March 24, 2:19pm ADT

March 24, 2:19pm ADT

User impact: Anonymous users may be unable to join Microsoft Teams meetings through the Safari browser.
More info: This issue is specific to non-authenticated Microsoft Teams meeting joins through the Safari browser. Current status: We've reverted the impacting update and we're monitoring service telemetry to ensure availability recovers completely. Scope of impact: This issue may affect any anonymous user attempting to join Microsoft Teams meetings through the Safari browser. Start time: Thursday, March 23, 2023, at 11:00 AM UTC Root cause: A recent update to service components facilitating authentication and meeting joining for anonymous users contains a code conflict that's causing impact. Next update by: Friday, March 24, 2023, at 7:30 PM UTC

Resolved

March 24, 2:40pm ADT

March 24, 2:40pm ADT

More info: This issue was specific to non-authenticated Microsoft Teams meeting joins through the Safari browser. Final status: We've confirmed through service telemetry that anonymous users are able to join Microsoft Teams meetings through the Safari browser, remediating impact. Scope of impact: This issue may have affected any anonymous user attempting to join Microsoft Teams meetings through the Safari browser. Start time: Thursday, March 23, 2023, at 11:00 AM UTC End time: Friday, March 24, 2023, at 5:40 PM UTC Root cause: A recent update to service components facilitating authentication and meeting joining for anonymous users contained a code conflict that was causing impact. Next steps: - We're reviewing the impacting update to identify how this issue wasn't caught during testing and validation, which will allow us to prevent similar impact in the future.
This is the final update for the event.