Unscheduled Outage
Incident
April 21, 9:05am ADT
Unscheduled Outage
Status: Closed
Start:
April 20, 11:49am ADT
End:
April 21, 9:05am ADT
Duration: 21 hours 16 minutes
Affected Components:
Browser Services
Update
April 20, 11:49am ADT
April 20, 11:49am ADT
The Microsoft 365 online services is currently experiencing a service outage. Technology Services is aware of the issue and Microsoft is investigating the cause.
Technology Services
will continue to provide regular updates.
Resolved
April 21, 9:05am ADT
April 21, 9:05am ADT
Please note that services with Microsoft 365 have been restored. If you continue to experience issues, please contact the Service Desk.
Copyright (C) 2021.